Name: Gilberto Tavares Velasco (email_not_shown)
Date: 04/21/03-07:52:59 AM Z


I have been using FeynCalc during the last four years and think I just have
found a possible bug in the OneLoop function. In particular, I recently had
to do some problem that involves the calculation of the following three
point tensor integral (I will use abbreviated FeynCalc notation from now

M=FVD[k, \[Mu]]SPD[k, p]SPD[k](FAD[{k + p - q, mw}, {k + p + q, mw},
{k,my}]-FAD[{k + p - q, mw}, {k + p + q, mw}, {k, mu}])

where k is the arbitrary momentum to be integrated, p and q are external
momenta, and mw, mu and mv the masses of the particles in the loop.

Note that the only difference in the terms in parenthesis is in the last
propagator, namely there is the change my->mu. It follows that M=0 when
my=mu. Guess what? I accidentaly found that something weird is going on. I
computed M as follows

T1=OneLoop[k,FVD[k, \[Mu]]SPD[k, p]SPD[k] FAD[{k + p - q, mw}, {k + p +
q,mw}, {k, my}]]

Then I evaluated the following

M=(T1-T2) /.mu->my

The result was of course zero.

However, I accidentaly tried the following alternative and apparently
unnecessary calculation:

S1=FVD[k, \[Mu]]SPD[k, p]SPD[k] FAD[{k + p - q, mw}, {k + p + q, mw},{k,my}]
S2=FVD[k, \[Mu]]SPD[k, p]SPD[k] FAD[{k + p - q, mw}, {k + p + q, mw},{k,mu}]


Just to check my result I evaluated

Simplify[M /.mu->my]

which did not returned zero. I did not panic since I knew that S1 and S2
were expressed in terms of Passarino-Veltman functions. Therefore, I used
the PaVeReduce function


Unfortunately the results was still not zero. I revised carefully the result
and there is no way that it is zero. I do not know if it has to do with a
problem with my computer or my FeynCalc installation. I am running
Mathematica 4.0 and have used FeynCalc and 4.1.1. Also, I have
tried linux and windows XP and the problem remains. I think it might be
related to a problem with the OneLoop function. I am attaching a (zipped)
notebook (bug.nb) with the calculation and all the output that I got. I
will appreciate any help. What am I doing wrong?


This archive was generated by hypermail 2b29 : 01/21/19-12:20:01 AM Z CET